ssossossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Reference to __CG__OroBundleWorkflowBundleEntityWorkflowStep.php

This topic contains 11 replies, has 3 voices, and was last updated by  tony7671 3 years, 8 months ago.

  • Creator
    Topic
  • #23309

    tony7671
    Participant

    When I ran:

    php app/console oro:install –env prod

    it showed the requirements were met, then showed:

    I can’t figure out where __CG__OroBundleWorkflowBundleEntityWorkflowStep.php should be coming from.

    Can anyone help?

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #23310

    Yevhen Shyshkin
    Participant

    Hello, tony7671.

    Could you manually remove all directories from app/cache (rm -rf app/cache/*) and try to install application again?

    #23311

    tony7671
    Participant

    Thanks – that got me a bit further. During the install now though I get:

    #23312

    Yevhen Shyshkin
    Participant

    Now you have the error with nodejs (node: not found) – you have to install nodejs and ensure than “node” command is available from console.

    #23313

    tony7671
    Participant

    I got past that point, and it seemed to install okay. Now however, I can’t figure out what to do to run it. It’s installed locally on:

    http://192.168.1.100/orocrm

    and the Apache server is working to that directory. I can’t see any default file though, or a .htaccess file to deal with references.

    Thanks,

    Tony

    #23314

    Yevhen Shyshkin
    Participant

    Please, ensure that .htaccess is used by Apache (.htaccess is in /web directory), and then try to access this directory (i.e. http://192.168.1.100/orocrm/web).

    Also I’d recommend you to create separate virtual host for application (https://github.com/orocrm/documentation/blob/master/cookbook/how_to_install_oro_platform.rst#set-up-virtual-host) – in this case you can specifiy subdirectories and custom preferences exactly for this instance of application.

    #23315

    tony7671
    Participant

    I did manage to get a little further – the virtual server is set up, pointing to the right directory, and I think the .htaccess is working. However, all I seem to get is a blank page – source looks like this:

    Do you have any ideas what to try next?

    Thanks

    #23316

    Yevhen Shyshkin
    Participant

    Please, put here your virtual host configuration and content of error log from your web server. Look’s like that for some reason it can’t execure php files.

    #23317

    tony7671
    Participant

    Aha – found this in the logs:

    I opened set the permissions to 777 and it runs, so it is a permissions issue. I’ll figure out how to set them a bit tighter.

    Decided I should do a clean install – now got to the point where this happens:

    We were really worried about the stability of the installation process. We were really attracted to this as a Magento compatible CRM, but concerned that in operation these sort of cryptic errors might occur.

    Thanks

    #23318

    tony7671
    Participant

    Got round that by logging into Github to bypass the rate limiting.

    Now getting:

    even after clearing app/cache.

    Sooooo frustrating!!!!

    Thanks

    #23319

    Dima Soroka
    Keymaster

    Please update xdebug.max_nesting_level to 250.

    #23320

    tony7671
    Participant

    I found another way round – it was being caused by xdebug turned on, so it seems to be working at the moment.

    Thanks for your help!

    Tony

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.