ssossossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums Forums OroCommerce message queue processing

This topic contains 7 replies, has 4 voices, and was last updated by  msulima 8 months, 3 weeks ago.

  • Creator
    Topic
  • #31986

    saqibbhat96
    Participant

    Hello all,
    i have orocommerce 1.0 running, but changes to web catalog doesnot seem to show at frontend when it comes to adding new pages or overall reindexing of catalogs

    I tried running this command, but no response nor output?

    in addition i ran this command to check available extensions,

    and it seems the queue management has not installed or configured yet ?

    Please assist
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #31987

    Michael
    Participant

    You can add -vvv to the command to see the debug output:

    #31988

    saqibbhat96
    Participant

    Thanks for the reply @Michael.
    Here is the output of this command.

    #31989

    saqibbhat96
    Participant

    Hello,

    Regarding the message queuing, i got this alert msg when running the command

    please assist
    Thanks

    #31990

    msulima
    Moderator

    Hi,
    the ‘orphan’ messages appear if a dbal transport is used when:
    1. A consumer processes a message
    2. The consumer is interrupted for some reason, but the message is still assigned to it.
    3. A consumer is restarted (actually it is a new consumer)
    4. The message is still assigned to the ‘old’ consumer.

    Such messages are checked periodically by working consumers and are re-queued if found. It is a part of a normal consuming flow.

    #31991

    saqibbhat96
    Participant

    thanks for the reply @msulima,

    after this alert message, the process keeps on running with no output and never ends.
    My question is how would i know the message queuing has setup correctly?
    please help…..thanks

    #31994

    msulima
    Moderator

    Try to run

    in another terminal window and check if some output appears in the consumer console.

    #31992

    tparys
    Participant

    Hi there!

    It looks like there’s nothing wrong in the output you’ve copied – the message consumer is running and processing correctly. Please keep it running while changing the Web Catalog data – after clicking “Save” you should notice some new messages in the pipeline and changes should be reflected.

    If the message queue would not be running correctly, you would not be able to run the message consumer at all. Instead, it would fail with an error message.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.