Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums Forums OroCRM OroCRM – How do I? Questions Calendar invitation notifications

This topic contains 2 replies, has 2 voices, and was last updated by  daumantas 2 years, 6 months ago.

  • Creator
  • #25619



    We’re using oro/platform 1.7.0 and oro/crm 1.7.0

    When I create calendar event and add another user as guest, the user don’t get email notification.
    Notifications don’t work for all users, not just me.

    Has anyone encountered this problem? How can I fix it?
    <…> Perhaps the most requested calendar feature has made its way to OroCRM and will debut in version 1.5—invitations to calendar events. This feature will give the user the ability to invite other OroCRM users to events, send them email notifications about this invitation and receive feedback about their responses or lack thereof. <…>

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #25620

    Artem Liubeznyi

    Hi daumantas,

    Can you please provide more details of your setup? I just have tried the invite functionality on our demo site ( and it worked as expected.


    Please check if your mailing server is configured properly, and if the job queue daemon (namely, “swiftmailer:spool:send”) is active.




    Thanks for reply 🙂

    I’ve tried “gmail”, “mail” and “smtp” as mailer transport, but none of them worked.

    Current configuration in parameters.yml:
    mailer_transport: smtp
    mailer_password: ********
    mailer_port: 587
    mailer_encryption: ssl

    I’ve also tried debugging code. Email should be sent on vendor\oro\platform\src\Oro\Bundle\NotificationBundle\Processor\EmailNotificationProcessor.php:123.
    $this->mailer->send($message) returns “1” as it was sent. But I don’t see any activity in the mail log on the server. This email account works on Thunderbird (same settings). Also, “forgot your password” email on CRM works.
    Each time I change parameters.yml, I run command “php app/console cache:clear –env=prod –no-debug”.

    “php app/console –env=prod oro:cron” is set in a crontab.
    I’ve also tried to run “php app/console –env=prod swiftmailer:spool:send” manually:
    “Processing default mailer… 0 emails sent” – always same response.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.