Forums OroCRM CPU 100%

This topic contains 5 replies, has 2 voices, and was last updated by  Rodolfo 2 years, 1 month ago.

  • Creator
  • #27159


    each refresh CPU consumption of my server (4 Hearts 2.7 and 6G RAM + APC) amounts to 100%. It takes about 10 seconds for each action. for the loggin page I have to wait about 1 minute.
    Do you have an idea ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
  • #27160


    Hi @brunpatoch

    Is your xdebug enabled? Did you change any cache config? Are you running in prod or dev mode? What version of platform are you using?



    Hi @Rodolfo,
    xdebug is disabled, I am prod environment. My orocrm version is 1.7.



    I would say that the first think I can imagine about CPU 100% while loading page is something weird like xdebug enabled or dev mode enabled forcing the generation of new cache files every time.

    I know the dashboard sometimes is heavy because it calls some heavy queries from DB. Is that problem happening only on home page after login? If yes, have you tried to remove the dashboard widgets to compare the performance?

    A nice point of start would be investigate if the CPU spike is coming for PHP, MySQL, or WebServer. Are you running your database on the same webserver?

    That was my experience, maybe someone else may have another ideas.
    Good luck!



    hi @Rodolfo Thank you for your answer.
    When I do a “top”, my httpd processes is 100%, php and mysqld are ok.
    On your advice I created a empty dashboard, but the loading time is also very slow.
    The consultation takes about 10s but it is almost impossible to create or modify objects, about 2 minutes of waiting.

    How can I be sure that my cache is enabled and functioning properly (eg writing problem)?



    I would try to switch from Apache to (Nginx + php-fpm). What do you think?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.