ssossossossosso

Forums

Forums OroCRM OroCRM – Programming Questions Cannot figure Roles

This topic contains 12 replies, has 4 voices, and was last updated by  ishakuta 4 years ago.

  • Creator
    Topic
  • #22056

    southside
    Participant

    Is it possible to disable/hide “Accounts” and hide all references from menus etc for a user.

    I have created a new role and added a test user to it.

    However all elements in the Role are none by default and I cannot see how to filter what elements I want each role to have access to.

    Is this maybe not working yet?

    I have tried FF, IE, CHROME it looks like maybe when you click on None it is meant to swap with Javascript but nothing happens.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Author
    Replies
  • #22057

    southside
    Participant

    Can anyone please respond today Friday and advise how ROLES work.

    I cannot see how to change the NONE status of a new role to allowed?

    We need to decide today if OROCRM will work for our client project or ZURMO CRM.

    Also do you offer paid for business level support on OROCRM?

    As we need this for a client project until you have a stable release.

    #22058

    southside
    Participant

    Okay I can see your demo works and our install gets an error.

    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    GET http://domain.com/crm-application/web/security/acl-access-levels/entity%3AOroCRM%5CBundle%5CAccountBundle%5CEntity%5CAccount 404 (Not Found) oro.min.js:356
    send oro.min.js:356
    ht.extend.ajax oro.min.js:356
    (anonymous function) oro.min.js:357
    ht.event.dispatch oro.min.js:355
    v.handle

    We will update to the latest version and see if that fixes the issue.

    #22059

    ishakuta
    Participant

    What version do you use? If not latest – try to update, cause I can’t reproduce your issue with latest dev (created test role without account view perms, new user and assign user to this role).
    Chrome Version 31.0.1650.63 Ubuntu 13.10 (31.0.1650.63-0ubuntu0.13.10.1~20131204.1)

    #22060

    southside
    Participant

    Can you just pull the latest version and overwrite files or do you need to do a new install.

    Also how can I tell what version I am on?

    It is maybe a week or two old.

    #22061

    southside
    Participant

    We installed on 13th December looks pretty current.

    #22062

    Vova Soroka
    Participant

    The problem is happened on some PHP installations and it related with backslashes in URL. The fix will be available in the closest release.

    #22063

    southside
    Participant

    Okay does that mean I download and re-install a new version now?

    We are trying to evaluate OROCRM for a client project even although it is in BETA our alternative is ZURMO but we like OROCRM as it best suits the client requirements.

    Is there a way to pull the newest version without a complete re-install and database dump?

    #22064

    Alexandr Smaga
    Participant

    Hello,

    Latest release is 1.0.0-beta5. It was published 15 days ago, so seems that you have the latest one.

    Is there a way to pull the newest version without a complete re-install and database dump?

    Basically yes, database could be updated by native doctine:schema:update command, code will updated by git pull.

    But anyway there are some risks, keep this in mind.

    #22065

    southside
    Participant

    Okay we have done that but we still get PHP issues.

    We have CentOS 6.5 and PHP 5.4.23 and we get issues with ROLES selection boxes not working and edit the address widget and the pin to task bar and the country state fields.

    Your demo has none of these issues but we cannot get PHP version 5.4.22 installed which is what you seem to have.

    Can you confirm what version of PHP and CentOS we should have or is it another issue.

    We just want a working demo like yours but that seems hard to achieve.

    Please help.

    #22066

    Alexandr Smaga
    Participant

    It’s very strange, because it should work on your php version as well. Did you have previous versions installed on your current domain, maybe js/css cache issue ? Have you tried to clear browser cache?

    #22067

    southside
    Participant

    After a few days of trying to fix these issues we have come to a dead end.

    If we supply you SSH details to a virgin install of CentOS 6.5 on a new physical server will you be able to get it installed.

    We had it running but in trying to fix the issues we had it seems to have created other issues.

    We would like to get a working version like your demo.

    We could then build on that.

    If you can do this please advise where I can private message the SSH details.

    #22068

    ishakuta
    Participant

    So, have you got system installed already?

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.