ssossossossosso

Forums

This topic contains 13 replies, has 7 voices, and was last updated by  Mike Kudelya 1 year, 7 months ago.

  • Creator
    Topic
  • #23647

    Jarzyn
    Participant

    Hi,
    while trying to upgrade we get the following error

Viewing 13 replies - 1 through 13 (of 13 total)
  • Author
    Replies
  • #23648

    smartroot
    Participant

    Welcome to OROCRM!

    #23649

    Yevhen Shyshkin
    Participant

    Hello, Jarzyn.

    Could you, please, try to manually remove cache (rm -rf app/cache/*) and then run update again?

    If it will not help – please, put here previous version of OroCRM you had used – I’ll try to reproduce this issue.

    #23650

    Jarzyn
    Participant

    We had fetched OroCRM from git head@13.08.2014 (ba33db1) and tried to update to 1.4 stable branch with instruction from UPGRADE.md.

    #23651

    Yevhen Shyshkin
    Participant

    Look’s like you are trying to update from 1.3.0 to 1.4.0. I’ve tried to perform this update on clear instance with demo data and got no errors – here is my migration log https://gist.github.com/yshyshkin/8b2c00a9469e31a1fb47. Maybe you’ve already updated to one of night build revisions between 1.3.0 and 1.4.0?

    Also, could you, please, check whether directory app/cache/prod/oro_entities/Extend/Entity contains files EV_Lead_Source.orm.yml and EV_Lead_Source.php? If no you can manually remove cache and then do php app/console cache:clear --env prod to regenerate cache – after that these files must be generated, and so update should be processes without problems.

    If it will not help – please, try to rollback to your 1.3.0 database state and try to do direct update 1.3.0 => 1.4.0 with fresh cache.

    #23652

    annuksun
    Participant

    Hi Guys,

    Is anyone looking after this thread?
    I’m installing OroCrm from a scratch and I’m receiving an error

    [Doctrine\Common\Persistence\Mapping\MappingException]
    Class ‘Extend\Entity\EV_Lead_Source’ does not exist

    I tried all advices that were posted here but no luck. An error is still the same. What can I do about it?
    Please help.

    #23653

    It seems that forum is dead. And project as well.

    #23654

    Dima Soroka
    Keymaster

    @annuksun – This thread was about upgrade, could you please clarify how you installation issue is related to it? As for issue with install – please provide more details on which version you are trying to install, environment and steps to reproduce.

    @Евгений – please clarify your conclusion, are you actively following our forum, github updates and blog?

    #23655

    annuksun
    Participant

    Hi Dima,

    Thanks for your quick reply.
    Essentially, I’m trying to follow the installation guide published at this website.
    I receive this error when I launch php app/console oro:install –env=prod in the shell.

    I must confess, even though I have some technical background and I used to admin and manage linux servers, my knowledge is quite obsolete. I’ve managed to get through most of the steps however this issue I cannot overcome so your help would be greatly appreciated. Please let me know what kind of details (outputs of commands) do I need to provide you with so that you could help.

    I really need this OroCrm up and running since I’ve realised that this is the only solution that will smoothly work with my magento shop and provide me with all the CRM data that I need for my business.

    So I’m really hope you can help me to finalise the installation.

    Thanks

    #23656

    Dima Soroka
    Keymaster

    Please make sure you are using latest stable version

    please share installation log from app/logs/oro_install

    #23657

    annuksun
    Participant

    Hi Dima,

    I’ve tried with the latest stable version. An error is still the same.
    There is no log at app/logs/oro_install (probably because I’m using shell for installation)

    However, this is what I see in the output in the shell.

    Please advise what I can do.

    Thanks.

    #23658

    Mike Kudelya
    Moderator

    Hi!

    Which commands did you run?
    Does database user has permissions to create/update tables?
    Does linux user has full permissions to oro directory?
    Does database contain any tables before installation?
    What version of php do you use?
    What database do you use, mysql or postgreSQL?

    You should prepare empty database, fresh clone and run following commands:

    Clone project:

    Prepare vendor directory:

    Install:

    #23659

    annuksun
    Participant

    Hi Everyone,

    Big thx for all your help.
    I completely removed orocrm folder, dropped database and made a fresh installation following mikekudelya advice.
    Everything was installed perfectly. It is working now. Huarray!

    Unfortunately, I did a stupid mistake and filled database with a sample data. So the only question I have is whether it is possible to removed all this data without reinstalling the whole application.

    Thanks a lot for help!

    #23660

    Mike Kudelya
    Moderator

    Hi!

    I think you better reinstall application, because there is no command that removing sample data.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.