Forums OroCRM OroCRM – Installation/Technical Issues or Problems OroCRM quick local installation with Vagrant

This topic contains 5 replies, has 2 voices, and was last updated by  Nik 1 year, 2 months ago.

  • Creator
  • #24756


    Hi, all!

    I’ve made a Vagrant provision script for OroCRM local installation (for “the first look,” local development, etc. purposes – like Homestead project for Symfony and Laravel). So I would appreciate feedback on it.


    Actually, this provisioner suitable for all OroPlatform-based applications, nut just OroCRM.

    So, to install OroCRM locally this way you have to:

    The installation process will take about 10-15 mins. Then you can access to application frontend by URL http://localhost:8000/ in your browser with login: admin, password: adminpass.
    For more detailed instructions, please, see file.

    As I said, I would appreciate any feedback. Here or on a GitHub site.

    Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
  • #24757

    Tin Pham

    Thank you for your work! It helps me a lot because I also tried to set up a similar installation.

    But I had some issue when trying to ssh to the VM after the installation finished.
    The Ubuntu Xenial seems to be not compatible with vagrant, and it ask for ubuntu user password.
    I posted this issue on github but then I tried to work around it and everything is quite ok now.

    Thank you again.



    Tin Pham, thank you for the feedback!

    I just replied on Github (for some reason I did not receive notification about opened Issue)

    The main point of my answer is there was some error during initialization of Vitualbox virtual machine and
    vagrant destroy and then vagrant up could help.

    Please, let me now if it’s everything ok now and you don’t mind closing Issue on Github.

    Thank you!


    Tin Pham

    Ni Nik, I have some problem with the “Job Queue”. System > Job Queue

    The Deamon status: Not running
    Deamon PID: N/A

    This pretends all commands to be executed. Do you have the same error?


    Tin Pham

    I found this link and it solved the problem with the job queue.

    No Run Daemon Button



    Hi, Tin.

    Yes, “Not running” daemon – it’s kinda feature – I decided, rather, it’s not necessary to set up ‘oro:cron’ job in crontab. Because it could burden the VM when a developer doesn’t need this. And the developer can start it manually any moment if needed. What do you think about it?

    Probably I’ll add a note about this to the README file later, for clarity, thank you.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.