Forums OroCRM OroCRM – How do I? Questions Email sync problems

This topic contains 32 replies, has 6 voices, and was last updated by  ianfp 1 year, 3 months ago.

  • Creator
  • #25948


    I’m having a tough time with email sync. I’ve added two system mailboxes, given myself access to them via the “Access Management” rules, and configured both of them to create new cases. Both mailboxes are able to access the IMAP server (Google Apps for Business) and are configured to import email from one specific folder each. I have the ‘oro:cron’ task running in the background, and I can see activity in the System > Job Queue.

    But… when I send email to either address, it is not imported nor is a case created. When my coworker sends an email to one of them (“webmaster”), it IS imported, but a case is NOT created. When he sends an email to the other address (“support”) it is NOT imported NOR is a case created.

    The two mailboxes are different folders in different Gmail accounts, but the IMAP configuration for them in Oro is otherwise identical. The support mailbox is also being read by our current CRM (SugarCRM, which I am trying to migrate away from).

    I’m at a loss for why only some emails sync, and why no cases are created. I need EVERY email send to either account to be synced and to be converted into a case.

    Any help is most appreciated.

Viewing 15 replies - 1 through 15 (of 32 total)
  • Author
  • #25949


    I realize that my question above is quite broad. Perhaps I can start with two simpler questions:

    1) How can I import EVERY email that comes into a system mailbox, rather than just ones that come from an existing contact? (Indeed, what is the rationale behind this behavior? I expect to get email from potential new customers — I certainly don’t want to miss them!)

    2) When the imap:sync job runs, it says “Skip <email subject> (UID: XXX) email, because it was sent earlier than the last synchronization was done”. How can I reset the last sync time so that those emails can be imported?



    Artem Liubeznyi

    Hi Ian,

    Your #1 problem is very perplexing. Our system mailboxes must import all email from the folders you have selected, and we’ve dropped the existing contact requirement way back in 1.8 version. I will ask our QA to verify this, as it is definitely not the intended behavior.

    Answering the #2, there is no way to do this from the UI, and you’ll have to do some custom development to make it work your way. We have decided to not import the existing emails for system mailboxes to avoid long and resource-consuming initial mailbox sync as well as avoid getting into situations when new leads or cases will be created from bygone conversations. The system mailbox in OroCRM is a fresh start.



    Hi Artem, thanks for getting back to me.

    Problem #1 is not what I thought it was. I think the problem is that the folder I selected to sync from was lost when I added “Convert to case” processing. The steps to reproduce this problem are:

    1) Add a new system mailbox
    2) Enable IMAP
    3) Retrieve folders and select one
    4) Save and Close
    5) Edit the new system mailbox
    6) Select “Convert to Case” from “Email processing”
    7) Now look, your selected folder has been unchecked

    So I thought it was reading from the selected folder but in fact the folder had been de-selected without my noticing!

    Regarding issue #2, can I force a resync of older emails by changing the oro_email_origin.synchronized column? If so, perhaps I could write a console command for recovering missing emails.


    Artem Liubeznyi

    Oh, that is a known bug. We’re already working on it and should release the fix in 1.9.1 version soon.

    Regarding the #2, I will consult with our developers and will get back to you.



    Artem, I have more information about #2. If I edit a system mailbox, it updates the last sync time (the oro_email_origin.synchronized column). I have a few emails that didn’t get imported; they were sent at about the time I was tweaking the mailbox configuration. I can see in the Job Queue that they were skipped because they were “sent earlier than the last synchronization was done”.

    Is that a possibility? If so, it would be bad to miss customer emails just because I was changing the mailbox configuration.



    Here’s some more information about #2. In the afternoon, imap-sync stops working entirely. Here’s what happens:

    – The Job Queue will show, say, 11 emails.
    – I’ll send an email to the mailbox.
    – One minute later, the next run of imap-sync shows 12 emails, and says the new email was skipped because it was sent earlier than the last run.

    Things work in the morning, but in the afternoon I feel like emails are “falling through the cracks”, if you know what I mean. Could this be a timezone or clock synchronization issue? My server is running ntpd and the time is correct.


    Artem Liubeznyi


    Thanks for the information. We were able to reproduce it and will do our best to fix this bug in 1.9.1 version. I will get back to you when it’s done.

    On the question of forcing the re-sync of older emails: your method is fine, but to make it work you have to change two values: oro_email_origin.synchronized for the mailbox and oro_email_folder.synchronized for the specific folder.

    Hope that helps.




    Thanks very much for your ongoing support — I’m very grateful.

    I realized yesterday your point about updating both “synchronized” columns — thanks for confirming.

    I’ll mark this thread as resolved once 1.9.1 is released and I’ve confirmed the fix.




    We have configured email using Gmail (Free one) SMTP and IMAP with all folders sync (including Sent)

    now when i sent email from Oro It dosent show in sent email under gmail

    same when i sent email from gmail it dont show up in Oro

    Can you guide me where is the problme


    Artem Liubeznyi


    Please answer a few questions to help us to identify the problem.

    Did you configure your mailbox as standard IMAP, or used OAuth for Gmail?

    Do you experience any problems with receiving email, or this problem affects sent messages only?



    Hey Artem

    Thanks for quick response

    we configured email as standard IMAP

    and we are able to receive email , and problem is only for sent messages only



    if you want to check my setup i can show by skype my skype id is jigneshthummar


    Artem Liubeznyi

    What SMTP server/port have you used?



    here are my settings

    IMAP 993 and SMTP 465


    Artem Liubeznyi

    Have you seen the message about SMTP connection being established successfully when you set up the mailbox? Like this one:

Viewing 15 replies - 1 through 15 (of 32 total)

You must be logged in to reply to this topic.