Forums OroPlatform OroPlatform – Installation/Technical Issues or Problems Installation FAiled on Step 3 – Failed migrations – OroUserBundleInstaller

This topic contains 1 reply, has 1 voice, and was last updated by  mattmuffin 2 years, 3 months ago.

  • Creator
  • #29649



    I’ve been struggling to install ORO CRM on a brand new server runninf Ubuntu 14.10 / nginx 1.8

    Here’s what i’ve tried:

    # php app/console doctrine:database:create

    => fails with this message: PHP Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[42000] [1049] Unknown database ‘oro_crm” in /opt/crm-application/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43

    Solution: create database oro_crm using the mysql prompt and relaunch.

    Launching the install script:

    # php app/console oro:install –env=prod

    => fails with this message: > Oro\Bundle\EntityExtendBundle\Migration\UpdateExtendIndicesMigration – skipped

    Failed migrations: Oro\Bundle\UserBundle\Migrations\Schema\OroUserBundleInstaller.

    oro:migration:load [–force] [–dry-run] [–show-queries] [–bundles [BUNDLES]] [–exclude [EXCLUDE]] [–timeout [TIMEOUT]] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-s|–shell] [–process-isolation] [-e|–env ENV] [–no-debug] [–jms-job-id JMS-JOB-ID] [–current-user CURRENT-USER] [–current-organization CURRENT-ORGANIZATION] [–disabled-listeners DISABLED-LISTENERS] [–] <command>

    The command terminated with an exit code: 1.

    Tried using the web interface, fails during schema update step; nothing shows up in the app/logs/oro_install.log after the list of bundles/migrations.

    Any help would be greatly appreciated

    Thank you

Viewing 1 replies (of 1 total)
  • Author
  • #29650


    Hello again,

    The command:

    # php app/console oro:install –env prod –drop-database –force –timeout=3000

    seems to do the trick. Is there a way you guys could fix the web interface installer?

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.